Celestial Impact Forum Index
Author Message

<  Support  ~  Shader error

Sniper TY
Posted: Fri Sep 23, 2011 10:21 pm Reply with quote
Joined: 23 Sep 2011 Posts: 1
I'm running Windows 7
I updated my graphics driver after discovering it didn't work (still doesn't work)
this looks like my Exact kind of game I like, so if there's some kind of guide to fix this- please point me in the right direction.
-----------------------------------
--------- CI ERROR DUMP ---------
-----------------------------------
Error time: 2011-09-23 14:11:37
Error Msg: "game/base/shaders/shadow.shader" did not link successfully

Subtract 100 from line number to get correct line number



You will not be able to run Celestial Impact in client mode

Engine Version: 1.10b

OpenGL Extensions:

GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_EXT_texture_swizzle GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_EXT_framebuffer_blit GL_ARB_vertex_array_object -----------------------------------

=========================== CONSOLE ===========================
-------- Celestial Impact v1.10b --------
Build: WIN32-IA-32-RELEASE Jun 6 2008 17:21:41
Starting Celestial Impact at: 2011-09-23 14:11:22
Command line: ""
Get system info...
CPU: 2 GenuineIntel 2194 MHz with MMX & SSE
Mem: 1023 MB Free: 1023 MB
OS: 5.1 Service Pack 3
Startup File System...
Current Path: "C:/Users/Tyler Yeager/Desktop/ci_110b_full/"
........... Base_Imp ...........
Sys_InitNet: Initialize Network...
Socket version: 2.2
Setup UDP socket...
Sys_InitNet: bind( 14666 ) LOCAL successful
Get computer name...
My computer name: TylerYeager-PC
MY IP: 192.168.1.6
MY IP: 5.248.38.190
My Port: 14666
Sys_InitNet: Initialized network successful
Net_Init: sizeof( netPipe_t ) == 14036
Net_Init: Network up and running (my qport: 11999)
Loading pack files...
Loaded "game.pack" (cs: 9E4D3A2E) (1206 files)
Loaded "game1.pack" (cs: 0E24B87C) (69 files)
Loaded 2 packs in 47 ms
Loading Game Module: "game"...
Loaded GAME "Celestial Impact" version: 1.10b
........... Base_Imp Done ...........
........... Base_Init ...........
Game Module says HELLO!
Game module build time: Jun 6 2008 17:21:26
Resolved master address 213.114.175.70:15666
........... Base_Init Done (0 msec) ...........
CL_Init: Starting up client...
Sys_GetUserID: Loaded user id 0 from Win32 register
....................... R_Init .......................
dest_t = 28 light_t = 672 surfaces_t = 188
Loaded opengl32.dll successfully
Setup fullscreen mode successful
Window created successful (800*600)
Setup pixel format successful (color: 32 z: 24 stencil: Cool
Initializing WGL...
Created WGL context successful
WGL is up and running
Display mode successful (800*600*32 z: 24 stencil: 8 full: 1)
Initializing OpenGL...
OpenGL2.0 check successful
Vendor: Intel
Renderer: Mobile Intel(R) 4 Series Express Chipset Family
Version: 2.1.0 - Build 8.15.10.2413
OpenGL: 2.1
82 Extensions found
Max texture size: 4096 pixels
Max 3D texture size: 128 pixels
Max Cube texture size: 2048 pixels
Max texture anisotropy: 2x
Max texture units: 8
Max texture image units: 16
Max texture coords: 8
Max vertex texture image units: 16
Max clip planes: 6
Check OpenGL extensions...
Found: GL_EXT_texture_edge_clamp
Found: GL_ARB_texture_border_clamp
WGL_EXT_swap_control failed
Found: ARB_vertex_program
Found: ARB_fragment_program
Found: SGIS_generate_mipmap
Found: GL_EXT_framebuffer_object
Found: GL_EXT_texture3D
Found: GL_ARB_texture_cube_map
Found: GL_ARB_shader_objects
Found: GL_ARB_vertex_shader
Found: GL_ARB_fragment_shader
Found: GL_ARB_shading_language_100
Found: GL_ARB_occlusion_query
Found: GL_ARB_vertex_buffer_object
Found: GL_ARB_shadow
Found: GL_EXT_packed_depth_stencil
Found: GL_EXT_stencil_two_side
OpenGL is up en running
R_InitRenderTextures: Initialize render textures...
RB_InitRenderTextures: Initialize render 0 render textures in 7 msec
Init shaders...
========================= CONSOLE END =========================
View user's profile Send private message
creamola
Posted: Sun Oct 02, 2011 9:27 pm Reply with quote
Developer Joined: 04 Apr 2007 Posts: 136 Location: Stockholm, Sweden
Apologies for not monitoring this place lately. I will be forward your error to Coorn and he will hopefully be able to bring an answer.

_________________
Daniel Wikell
Game Design, 2D art and the rest of the stuff that noone else does
Celestial Impact
View user's profile Send private message
coorn
Posted: Sun Oct 02, 2011 9:44 pm Reply with quote
Developer Joined: 23 Jun 2007 Posts: 23 Location: Stockholm, Sweden
I really don't know why you can't run the game. Intel graphic cards historically have had some problems running games with hard core graphics, but since your card support OpenGL 2.1 it should be able to run it...

I am really busy with other projects right now so I don't have the time to take a closer look at this, I am really sorry.

_________________
Henning Tegen
Lead programmer, Celestial Impact
View user's profile Send private message
creamola
Posted: Mon Oct 17, 2011 7:14 am Reply with quote
Developer Joined: 04 Apr 2007 Posts: 136 Location: Stockholm, Sweden
Since you're on windows 7, you might be able to mess around some with compatibility options and get a better result.
This is a longshot for sure, but seeing how many other weird errors you tend to get from games not designed for win7 it might be worth checking out.

_________________
Daniel Wikell
Game Design, 2D art and the rest of the stuff that noone else does
Celestial Impact
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 1
Post new topic

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum