Celestial Impact Forum Index
Author Message

<  Support  ~  Another OpenGL problem

zecretw
Posted: Fri Aug 08, 2008 2:56 pm Reply with quote
Joined: 08 Aug 2008 Posts: 3
It seems like the detection algorithm does not work 100% Cool


-----------------------------------
--------- CI ERROR DUMP ---------
-----------------------------------
Error time: 2008-08-08 15:27:28
Error Msg: QGL_CheckOpenGL2: Bad OpenGL version (1.1)

Please download your graphic cards latest drivers

Your current graphic driver:
Microsoft Corporation GDI Generic

You will not be able to run Celestial Impact in client mode

Engine Version: 1.10b

OpenGL Extensions:

-----------------------------------

=========================== CONSOLE ===========================
-------- Celestial Impact v1.10b --------
Build: WIN32-IA-32-RELEASE Jun 6 2008 17:21:41
Starting Celestial Impact at: 2008-08-08 15:27:10
Command line: ""
Get system info...
CPU: 2 GenuineIntel 3380 MHz with MMX & SSE
Mem: 2047 MB Free: 2047 MB
OS: 5.1 Service Pack 2
Startup File System...
Current Path: "D:/GamesDemos/celestialInpact/"
........... Base_Imp ...........
Sys_InitNet: Initialize Network...
Socket version: 2.2
Setup UDP socket...
Sys_InitNet: bind( 14666 ) LOCAL successful
Get computer name...
My computer name: elsa3
MY IP: 192.168.254.2
MY IP: 192.168.42.11
MY IP: 192.168.0.3
My Port: 14666
Sys_InitNet: Initialized network successful
Net_Init: sizeof( netPipe_t ) == 14036
Net_Init: Network up and running (my qport: 29860)
Loading pack files...
Loaded "game.pack" (cs: 9E4D3A2E) (1206 files)
Loaded "game1.pack" (cs: 0E24B87C) (69 files)
Loaded 2 packs in 39 ms
Loading Game Module: "game"...
Loaded GAME "Celestial Impact" version: 1.10b
........... Base_Imp Done ...........
........... Base_Init ...........
Game Module says HELLO!
Game module build time: Jun 6 2008 17:21:26
Resolved master address 74.52.14.2:15666
........... Base_Init Done (20 msec) ...........
CL_Init: Starting up client...
Sys_GetUserID: Loaded user id 0 from Win32 register
....................... R_Init .......................
dest_t = 28 light_t = 672 surfaces_t = 188
Loaded opengl32.dll successfully
Setup fullscreen mode successful
Window created successful (800*600)
Setup pixel format successful (color: 32 z: 24 stencil: Cool
Initializing WGL...
Created WGL context successful
WGL is up and running
Display mode successful (800*600*32 z: 24 stencil: 8 full: 1)
Initializing OpenGL...
========================= CONSOLE END =========================


I can tell you that I am currently using a Saphire ATI 4870 graphics card with Caatalyst 8.7 driver. If this card does not support your game, what will? Sad

Driver Packaging Version 8.512-080703a-066900C-ATI
Catalyst® Version 08.7
Provider ATI Technologies Inc.
2D Driver Version 6.14.10.6833
2D Driver File Path System/CurrentControlSet/Control/Video/{1832D6B3-61C1-442C-9000-FCE8EABC80E2}/0000
Direct3D Version 6.14.10.0597
OpenGL Version 6.14.10.7769
Catalyst® Control Center Version 2008.0703.2236.38526
AIW/VIVO WDM SP Driver Version 6.14.10.6240
AV Stream (T200) Driver Version 6.14.10.1062

Primary Adapter
Graphics Card Manufacturer Built by ATI
Graphics Chipset ATI Radeon HD 4800 Series
Device ID 9440
Vendor 1002

Subsystem ID 0502
Subsystem Vendor ID 1002

Graphics Bus Capability PCI Express 2.0
Maximum Bus Setting PCI Express 2.0 x16

BIOS Version 011.003.000.001
BIOS Part Number 113-B50701-100
BIOS Date 2008/06/09

Memory Size 512 MB
Memory Type GDDR5

Core Clock in MHz 750 MHz
Memory Clock in MHz 900 MHz
Total Memory Bandwidth in GByte/s 107 GByte/s
View user's profile Send private message
creamola
Posted: Sat Aug 09, 2008 2:30 pm Reply with quote
Developer Joined: 04 Apr 2007 Posts: 136 Location: Stockholm, Sweden
From the looks of it, the game is detecting an integrated graphics card as primary instead of your real primary. Try disabling the onboard graphics completely and start the game again. To disable onboard graphics, venture into BIOS and set onboard graphics to off and make sure that the "init display first" is set to your real primary card. (I.e. if your card is PCIE, init display first should be set to PCIE)

_________________
Daniel Wikell
Game Design, 2D art and the rest of the stuff that noone else does
Celestial Impact
View user's profile Send private message
zecretw
Posted: Sat Aug 09, 2008 2:39 pm Reply with quote
Joined: 08 Aug 2008 Posts: 3
Thanks for your answer.

That would be my first thing to do also, if I had an intergrated graphicscard on my motherboard (Asus p5ad2-e premimum) wich I do not have.

Rolling Eyes

Sorry.

Is there any small software I could run to se if it detects my hardware OK?
View user's profile Send private message
coorn
Posted: Mon Aug 11, 2008 6:24 pm Reply with quote
Developer Joined: 23 Jun 2007 Posts: 23 Location: Stockholm, Sweden
It is strange that you have "Microsoft Corporation GDI Generic" as your current graphics driver. Are you sure you have downloaded the correct graphics driver from ATI and not some strange "Microsoft Generic" stuff? Smile

_________________
Henning Tegen
Lead programmer, Celestial Impact
View user's profile Send private message
zecretw
Posted: Tue Aug 12, 2008 7:38 am Reply with quote
Joined: 08 Aug 2008 Posts: 3
Solved!

It was something called "ASUS extended graphics driver" that prevented the detection of openGL. Dont ask me why, but after disabeling this "feature" in the device manager it worked perfectly.

Cool game. I realy liked the railgun Very Happy
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 1
Post new topic

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum