Celestial Impact Forum Index
Author Message

<  Support  ~  glGetError END CreateDepthStencil: GL_INVALID_ENUM

Posted: Fri May 16, 2008 5:17 pm Reply with quote
Joined: 16 May 2008 Posts: 4
Whenever I run the game, either regularly or as an Admin (Vista Business Edition) the game goes to full screen mode but stays a black background at a lower resolution. An audible error beep is heard. If I hit enter or spacebar the game disappears and I'm returned to the desktop. If I hit CTRL-ALT-DEL and go to the Task Manager, a window is visible that states "glGetError END CreateDepthStencil: GL_INVALID_ENUM".

Hardware is a Dell Inspiron 6400 with an ATI Mobility Radeon X1400. 2gb RAM, Core 2 Duo T7200 2.GHz.

Below is the information from the error file in the game folder:

--------- CI ERROR DUMP ---------
Error time: 2008-05-16 12:05:49
Error Msg: glGetError END CreateDepthStencil: GL_INVALID_ENUM

Engine Version: 1.00

OpenGL Extensions:

GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_fragment_shader GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_KTX_buffer_region GL_NV_blend_square GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_WIN_swap_hint WGL_EXT_swap_control -----------------------------------

=========================== CONSOLE ===========================
-------- Celestial Impact v1.00 --------
Build: WIN32-IA-32-RELEASE May 6 2008 17:34:44
Starting Celestial Impact at: 2008-05-16 12:05:48
Command line: ""
Get system info...
CPU: 2 GenuineIntel 1994 MHz with MMX & SSE
Mem: 2045 MB Free: 1067 MB
OS: 6.0
Startup File System...
Current Path: "C:/Games/CelestialImpact/"
........... Base_Imp ...........
Loading pack files...
Loaded "game.pack" (cs: 000385D5) (1206 files in 30 msec)
Loading Game Module: "game"...
Loaded GAME "Celestial Impact" version: 1.00
........... Base_Imp Done ...........
........... Base_Init ...........
Sys_InitNet: Initialize Network...
Socket version: WinSock 2.0
Setup UDP socket...
My computer name: FoRCe-New
Sys_InitNet: bind() LOCAL successful
My LAN Port: 14666
Sys_InitNet: Initialized network successful
Net_Init: sizeof( netPipe_t ) == 14036
Net_Init: Network up and running (my qport: 32692)
Game Module says HELLO!
Game module build time: May 5 2008 21:06:01
Resolving master address...
Resolved master address
........... Base_Init Done (53 msec) ...........
CL_Init: Starting up client...
Sys_GetUserID: Loaded user id 0 from Win32 register
....................... R_Init .......................
dest_t = 28 light_t = 672 surfaces_t = 188
Loaded opengl32.dll successfully
Setup fullscreen mode successful
Window created successful (800*600)
Setup pixel format successful (color: 32 z: 24 stencil: Cool
Initializing WGL...
Created WGL context successful
WGL is up and running
Display mode successful (800*600*32 z: 24 stencil: 8 full: 1)
Initializing OpenGL...
OpenGL2.0 check successful
Could not find glActiveStencilFaceEXT, use 2 pass shadow mode
Vendor: ATI Technologies Inc.
Renderer: ATI Mobility Radeon X1400
Version: 2.0.6465 Release
OpenGL: 2.0
75 Extensions found
Max texture size: 4096 pixels
Max 3D texture size: 2048 pixels
Max Cube texture size: 4096 pixels
Max texture anisotropy: 16x
Max texture units: 8
Max texture image units: 16
Max texture coords: 8
Max vertex texture image units: 0
Max clip planes: 6
Check OpenGL extensions...
Found: GL_EXT_texture_edge_clamp
Found: GL_ARB_texture_border_clamp
Found: WGL_EXT_swap_control
Found: ARB_vertex_program
Found: ARB_fragment_program
Found: SGIS_generate_mipmap
Found: GL_EXT_framebuffer_object
Found: GL_EXT_texture3D
Found: GL_ARB_texture_cube_map
Found: GL_ARB_shader_objects
Found: GL_ARB_vertex_shader
Found: GL_ARB_fragment_shader
Found: GL_ARB_shading_language_100
Found: GL_ARB_occlusion_query
Found: GL_ARB_vertex_buffer_object
Found: GL_ARB_shadow
Found: GL_EXT_packed_depth_stencil
GL_EXT_stencil_two_side failed
OpenGL is up en running
R_InitRenderTextures: Initialize render textures...
========================= CONSOLE END =========================
View user's profile Send private message
Posted: Fri May 16, 2008 9:53 pm Reply with quote
Developer Joined: 23 Jun 2007 Posts: 23 Location: Stockholm, Sweden
hmm ok, I will look at it. Thx for the help.
View user's profile Send private message
Posted: Fri May 23, 2008 12:53 am Reply with quote
Joined: 16 May 2008 Posts: 4
Let me know if you need any additional information. I'm anxious to check the game out Smile
View user's profile Send private message
Posted: Mon May 26, 2008 5:14 pm Reply with quote
Developer Joined: 23 Jun 2007 Posts: 23 Location: Stockholm, Sweden
Are you sure you using the latest graphics drivers? ATI don't give out there Mobility Radeon Drivers for Vista so you have to get the from dell.com

dell.com -> Support&Help -> Drivers&Downloads -> Vista -> Video -> X1400

Please report back if this don't fix the problem...
View user's profile Send private message
Posted: Wed May 28, 2008 12:12 am Reply with quote
Joined: 16 May 2008 Posts: 4
I am using the latest x1400 driver released on Dell's website (R153383). I checked last week to confirm that I have both the latest version of DirectX and the latest version of the video drivers installed and, to the best of my knowledge, my drivers are up to date.

That being said, this isn't the first game that I've had problems running in OpenGL mode. Pirates of the Carribean (yeah yeah) didn't run for me until I forced it to use DirectX.

If anyone has any suggestions for 3rd party video drivers please let me know Smile
View user's profile Send private message
Posted: Wed May 28, 2008 9:52 am Reply with quote
Site Admin Joined: 03 Apr 2007 Posts: 54 Location: Stockholm, Sweden
I just search some and found this:

As that is not supported by any company read the instructions carefully and make sure you know what you are doing. I havn't tried it I just found it, but it sounds good Smile.

Hopefully it will get CI running (and Pirate of the Carribean in OpenGL! yeah!).

Daniel Carlsson
Concept and 3D artist
Celestial Impact
View user's profile Send private message Visit poster's website
Posted: Sat May 31, 2008 11:07 pm Reply with quote
Joined: 16 May 2008 Posts: 4
Woot! That fixed it! I downloaded the latest ATI Catalyst drivers, used the Mobility Modder.NET utility, and now CI runs!

Thanks very much for the information - I may have never found out about Mobility Modder.net if it wasn't for you!
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 1
Post new topic

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum